blob: 7d0e5f205265cd0c6ca5b8778993552ca6f5c9fa [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Open client for Cisco AnyConnect VPN"
2LICENSE = "LGPL-2.1-only"
Andrew Geissler5082cc72023-09-11 08:41:39 -04003LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004
5SRC_URI = " \
6 git://git.infradead.org/users/dwmw2/openconnect.git;branch=master \
Andrew Geissler5082cc72023-09-11 08:41:39 -04007 file://0001-Shim-for-renaming-of-GNUTLS_NO_EXTENSIONS-in-GnuTLS-.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +00008"
Andrew Geissler5082cc72023-09-11 08:41:39 -04009SRCREV = "59f2e59eb3e436364ef82e630e5a2f88f32acd58"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
11DEPENDS = "vpnc libxml2 krb5 gettext-native"
12RDEPENDS:${PN} = "bash python3-core vpnc-script"
13
14PACKAGECONFIG ??= "gnutls lz4 libproxy"
15
16# config defaults
17PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls,"
18PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
19PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy,"
20
21# not config defaults
22PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite,"
23
24S = "${WORKDIR}/git"
25
26inherit autotools pkgconfig bash-completion
27
28EXTRA_OECONF += "--with-vpnc-script=${sysconfdir}/vpnc/vpnc-script \
29 --disable-static"
30
31do_install:append() {
32 rm ${D}/usr/libexec/openconnect/hipreport-android.sh
33}