Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Open client for Cisco AnyConnect VPN" |
| 2 | LICENSE = "LGPL-2.1-only" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | |
| 5 | SRC_URI = " \ |
| 6 | git://git.infradead.org/users/dwmw2/openconnect.git;branch=master \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 7 | file://0001-Shim-for-renaming-of-GNUTLS_NO_EXTENSIONS-in-GnuTLS-.patch \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | " |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 9 | SRCREV = "59f2e59eb3e436364ef82e630e5a2f88f32acd58" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | |
| 11 | DEPENDS = "vpnc libxml2 krb5 gettext-native" |
| 12 | RDEPENDS:${PN} = "bash python3-core vpnc-script" |
| 13 | |
| 14 | PACKAGECONFIG ??= "gnutls lz4 libproxy" |
| 15 | |
| 16 | # config defaults |
| 17 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls," |
| 18 | PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4," |
| 19 | PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy," |
| 20 | |
| 21 | # not config defaults |
| 22 | PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite," |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | inherit autotools pkgconfig bash-completion |
| 27 | |
| 28 | EXTRA_OECONF += "--with-vpnc-script=${sysconfdir}/vpnc/vpnc-script \ |
| 29 | --disable-static" |
| 30 | |
| 31 | do_install:append() { |
| 32 | rm ${D}/usr/libexec/openconnect/hipreport-android.sh |
| 33 | } |