blob: 4d132b761a6bcdf54280feef542a5be9ab39aef4 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
9 file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \
10"
11
12DEPENDS = "attr libaio libcap acl openssl zip-native"
13DEPENDS:append:libc-musl = " fts "
14EXTRA_OEMAKE:append:libc-musl = " LIBC=musl "
15EXTRA_OECONF:append:libc-musl = " LIBS=-lfts "
16
17# since ltp contains x86-64 assembler which uses the frame-pointer register,
18# set -fomit-frame-pointer x86-64 to handle cases where optimisation
19# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
20# earlier in CFLAGS, etc.
21CFLAGS:append:x86-64 = " -fomit-frame-pointer"
Andrew Geissler615f2f12022-07-15 14:00:58 -050022TUNE_CCARGS:remove:x86 = "-mfpmath=sse"
Patrick Williams92b42cb2022-09-03 06:53:57 -050023TUNE_CCARGS:remove:x86-64 = "-mfpmath=sse"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024
25CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
26CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Patrick Williams520786c2023-06-25 16:20:36 -050027SRCREV = "3ebc2dfa85c2445bb68d8c0d66e33c4da1e1b3a7"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000028
29SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \
30 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000031 file://disable_hanging_tests.patch \
Patrick Williams520786c2023-06-25 16:20:36 -050032 file://0001-testcases-kernel-syscalls-fcntl-define-_LARGEFILE64_.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000033 "
34
35S = "${WORKDIR}/git"
36
37inherit autotools-brokensep pkgconfig
38
Andrew Geissler78b72792022-06-14 06:47:25 -050039# Version 20220527 added KVM test infrastructure which currently fails to build with gold due to
40# SORT_NONE in linker script which isn't supported by gold:
41# https://sourceware.org/bugzilla/show_bug.cgi?id=18097
42# https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
43LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
Patrick Williams2a254922023-08-11 09:48:11 -050044LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' -fuse-ld=bfd', '', d)}"
Andrew Geissler78b72792022-06-14 06:47:25 -050045
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050046# After 0002-kvm-use-LD-instead-of-hardcoding-ld.patch
47# https://github.com/linux-test-project/ltp/commit/f94e0ef3b7280f886384703ef9019aaf2f2dfebb
48# it fails with gold also a bit later when trying to use *-payload.bin
49# http://errors.yoctoproject.org/Errors/Details/663094/
50# work around this by forcing .bfd linked in LD when ld-is-gold is in DISTRO_FEATURES
Patrick Williams2a254922023-08-11 09:48:11 -050051KVM_LD = "${@bb.utils.contains_any('DISTRO_FEATURES', 'ld-is-gold ld-is-lld', '${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}', '${LD}', d)}"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050052
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000053TARGET_CC_ARCH += "${LDFLAGS}"
54
55export prefix = "/opt/${PN}"
56export exec_prefix = "/opt/${PN}"
57
58PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
59EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
60EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
61# ltp network/rpc test cases ftbfs when libtirpc is found
62EXTRA_OECONF += " --without-tirpc "
63
64do_compile() {
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050065 oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}" KVM_LD="${KVM_LD}"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000066}
67
68do_install(){
69 install -d ${D}${prefix}/
70 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
71
72 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
73 # as it lacks dependency on some perl moudle such as LWP::Simple
74 # And this script previously works as a tool for analyzing failures from LTP
75 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
76 # http://khack.osdl.org to retrieve ltp test results run on
77 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
78 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
79
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000080 # The controllers memcg_stree test seems to cause us hangs and takes 900s
81 # (maybe we expect more regular output?), anyhow, skip it
82 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000083}
84
85RDEPENDS:${PN} = "\
86 attr \
87 bash \
88 bc \
89 coreutils \
90 cpio \
91 cronie \
92 curl \
93 e2fsprogs \
94 e2fsprogs-mke2fs \
95 expect \
96 file \
Andrew Geissler8f840682023-07-21 09:09:43 -050097 findutils \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000098 gawk \
99 gdb \
100 gzip \
101 iproute2 \
102 ldd \
103 libaio \
104 logrotate \
105 net-tools \
106 perl \
107 python3-core \
108 procps \
109 quota \
110 unzip \
111 util-linux \
112 which \
113 tar \
114"
115
Patrick Williams2a254922023-08-11 09:48:11 -0500116RRECOMMENDS:${PN} += "kernel-module-loop"
117
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000118FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
119
120# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
121INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
122INSANE_SKIP:${PN} += "already-stripped staticdev"
123
124remove_broken_musl_sources() {
125 [ "${TCLIBC}" = "musl" ] || return 0
126
127 cd ${S}
128 echo "WARNING: remove unsupported tests (until they're fixed)"
129
130 # sync with upstream
131 # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33
132 rm -rfv \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000133 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
134 testcases/kernel/syscalls/getcontext/getcontext01.c \
135 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
136 testcases/kernel/syscalls/timer_create/timer_create01.c \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500137 testcases/kernel/syscalls/timer_create/timer_create03.c
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000138}
139do_patch[postfuncs] += "remove_broken_musl_sources"
140
141# Avoid file dependency scans, as LTP checks for things that may or may not
142# exist on the running system. For instance it has specific checks for
143# csh and ksh which are not typically part of OpenEmbedded systems (but
144# can be added via additional layers.)
145SKIP_FILEDEPS:${PN} = '1'