Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "A C++11 library for serialization" |
| 2 | HOMEPAGE = "https://uscilab.github.io/cereal/" |
| 3 | |
| 4 | SECTION = "libs" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause & MIT & BSL-1.0" |
| 7 | LIC_FILES_CHKSUM = "\ |
| 8 | file://LICENSE;md5=4921372a1fb38469e667c38b17a1c4b3 \ |
| 9 | file://include/cereal/external/rapidxml/license.txt;md5=d63ab70ba21ca0544b03284958324301 \ |
| 10 | file://include/cereal/external/LICENSE;md5=b07578c9df99c0b8b45eb041efd4a645 \ |
| 11 | file://include/cereal/external/rapidjson/LICENSE;md5=e7abb663111d4ac17cf00323698aff08 \ |
| 12 | file://include/cereal/external/rapidjson/msinttypes/LICENSE;md5=dffce65b98c773976de2e338bd130f46 \ |
| 13 | " |
| 14 | |
| 15 | DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} " |
| 16 | |
| 17 | PROVIDES += "${PN}-dev" |
| 18 | |
| 19 | PV .= "+git${SRCPV}" |
| 20 | SRCREV = "ebef1e929807629befafbb2918ea1a08c7194554" |
| 21 | SRC_URI = "git://github.com/USCiLab/cereal.git;branch=master;protocol=https \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 22 | file://0001-sandbox-Do-not-use-int8_t-in-std-uniform_int_distrib.patch \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 23 | file://0001-cmake-Use-idirafter-instead-of-isystem.patch \ |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 24 | file://0001-doctest-Do-not-use-unnamed-class.patch \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 25 | file://run-ptest \ |
| 26 | " |
| 27 | |
| 28 | S = "${WORKDIR}/git" |
| 29 | |
| 30 | inherit cmake pkgconfig ptest |
| 31 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 32 | LIBATOMIC:mips = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}" |
| 33 | LIBATOMIC:riscv32 = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 34 | LIBATOMIC:powerpc = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 35 | |
| 36 | PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}" |
| 37 | PACKAGECONFIG[with-tests] = "-DWITH_WERROR=OFF -DBUILD_TESTS=ON ${LIBATOMIC},," |
| 38 | EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '', '-DJUST_INSTALL_CEREAL=ON', d)} \ |
| 39 | ${@['','-DSKIP_PORTABILITY_TEST=ON'][d.getVar('SITEINFO_BITS') != '32']}" |
| 40 | |
| 41 | do_install_ptest() { |
| 42 | install -d ${D}${PTEST_PATH}/tests |
| 43 | cp ${B}/unittests/test_* ${D}${PTEST_PATH}/tests |
| 44 | } |
| 45 | |
| 46 | ALLOW_EMPTY:${PN} = "1" |
| 47 | |
| 48 | RDEPENDS:${PN}-dev = "" |
| 49 | |
| 50 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | 5877637 | 2022-04-13 09:07:35 -0500 | [diff] [blame] | 51 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 52 | #it needs to work with CXXFLAGS += " -mlong-double-64" but ppc only supports 128bit long double |
| 53 | COMPATIBLE_HOST:powerpc:libc-musl = "null" |
| 54 | COMPATIBLE_HOST:powerpc64le:libc-musl = "null" |