blob: 5d7dbd8bda97db4c5a324da063d9abb682befa2d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design."
2SECTION = "libs/network"
3HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${S}/license.txt;md5=a2e15b954769218ff912468eecd6a02f"
6DEPENDS = "openssl websocketpp zlib boost brotli"
7
8EXTRA_OECMAKE = "-DCPPREST_EXPORT_DIR=cmake/cpprestsdk -DCPPREST_EXCLUDE_BROTLI=OFF -DWERROR=OFF"
9
10SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \
11 file://disable-float-tests.patch \
12 file://disable-outside-tests.patch "
13
Andrew Geissler7f40b712020-05-15 14:09:53 -050014# tag 2.10.16
15SRCREV= "18212a2a7967e12d740bfb957e500892b3463c88"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17S = "${WORKDIR}/git"
18
19inherit cmake pkgconfig