Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Bluetooth library with attribute support" |
| 2 | SECTION = "libs/network" |
| 3 | |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://CMakeLists.txt;beginline=1;endline=20;md5=8d5efeb9189b60866baff80ff791bf00" |
| 6 | |
| 7 | DEPENDS = "bluez5 glib-2.0" |
| 8 | DEPENDS += "glib-2.0-native" |
| 9 | |
| 10 | PV = "0.2+git${SRCPV}" |
| 11 | |
| 12 | SRC_URI = "git://github.com/labapart/gattlib.git" |
| 13 | SRC_URI += "file://dbus-avoid-strange-chars-from-the-build-dir.patch" |
| 14 | |
| 15 | SRCBRANCH = "master" |
| 16 | SRCREV = "c6a33252221dff904cf277e085e2ce70aced8788" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | PACKAGECONFIG[examples] = "-DGATTLIB_BUILD_EXAMPLES=ON,-DGATTLIB_BUILD_EXAMPLES=OFF" |
| 21 | |
| 22 | # Set this to force use of DBus API if Bluez version is older than 5.42 |
| 23 | PACKAGECONFIG[force-dbus] = "-DGATTLIB_FORCE_DBUS=TRUE,-DGATTLIB_FORCE_DBUS=FALSE" |
| 24 | |
| 25 | EXTRA_OECMAKE += "-DGATTLIB_BUILD_DOCS=OFF" |
| 26 | |
| 27 | inherit pkgconfig cmake |
| 28 | |
| 29 | FILES_${PN} = "${libdir}/* ${includedir}/*" |
| 30 | FILES_${PN}-dev = "${includedir}/*" |