blob: 4399edaab160e8b3d97629078b052e10f9f8bddd [file] [log] [blame]
James Feiste3322992018-10-04 16:15:37 -07001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
Brad Bishop2d39a062019-10-28 08:33:36 -04005LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f5f7c71504da070bcf4f090205ce1080"
James Feiste3322992018-10-04 16:15:37 -07006
7SRC_URI = "git://github.com/nlohmann/json.git"
8
Brad Bishop2d39a062019-10-28 08:33:36 -04009PV = "3.7.0+git${SRCPV}"
James Feiste3322992018-10-04 16:15:37 -070010
Brad Bishop2d39a062019-10-28 08:33:36 -040011SRCREV = "ea60d40f4a60a47d3be9560d8f7bc37c163fe47b"
James Feiste3322992018-10-04 16:15:37 -070012
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
18
19# nlohmann-json is a header only C++ library, so the main package will be empty.
20
21RDEPENDS_${PN}-dev = ""
22
23BBCLASSEXTEND = "native nativesdk"
James Feistcb07cdf2018-10-11 13:47:04 -070024
25# other packages commonly reference the file directly as "json.hpp"
26# create symlink to allow this usage
27do_install_append() {
28 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
29}