Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Open Source multimedia player" |
| 2 | DESCRIPTION = "mpv is a fork of mplayer2 and MPlayer. It shares some features with the former projects while introducing many more." |
| 3 | SECTION = "multimedia" |
| 4 | HOMEPAGE = "http://www.mpv.io/" |
| 5 | DEPENDS = "zlib ffmpeg jpeg virtual/libx11 xsp libxv \ |
| 6 | libxscrnsaver libv4l libxinerama \ |
| 7 | " |
| 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
| 10 | |
| 11 | LICENSE = "GPLv2+" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=91f1cb870c1cc2d31351a4d2595441cb" |
| 13 | |
| 14 | # While this item does not require it, it depends on ffmpeg which does |
| 15 | LICENSE_FLAGS = "commercial" |
| 16 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 17 | SRCREV_mpv = "4db82f04502cbcd20d9a975df9dfde91d8c389e3" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | SRC_URI = " \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 19 | git://github.com/mpv-player/mpv;name=mpv \ |
| 20 | http://www.freehackers.org/~tnagy/release/waf-1.8.12;name=waf;downloadfilename=waf;subdir=git \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 21 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | SRC_URI[waf.md5sum] = "cef4ee82206b1843db082d0b0506bf71" |
| 23 | SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b" |
| 24 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 25 | S = "${WORKDIR}/git" |
| 26 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 27 | inherit waf pkgconfig pythonnative features_check |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 28 | |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 29 | LUA ?= "lua" |
| 30 | LUA_mips64 = "" |
| 31 | LUA_aarch64 = "" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 32 | # Note: both lua and libass are required to get on-screen-display (controls) |
| 33 | PACKAGECONFIG ??= " \ |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 34 | ${LUA} \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 35 | libass \ |
| 36 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \ |
| 37 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 38 | |
| 39 | PACKAGECONFIG_remove_aarch64 = "lua" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 40 | PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm" |
| 41 | PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/mesa" |
| 42 | PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua luajit" |
| 43 | PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass" |
| 44 | PACKAGECONFIG[libarchive] = "--enable-libarchive,--disable-libarchive,libarchive" |
| 45 | PACKAGECONFIG[jack] = "--enable-jack, --disable-jack, jack" |
| 46 | PACKAGECONFIG[vaapi] = "--enable-vaapi, --disable-vaapi,libva" |
| 47 | PACKAGECONFIG[vdpau] = "--enable-vdpau, --disable-vdpau,libvdpau" |
| 48 | PACKAGECONFIG[wayland] = "--enable-wayland, --disable-wayland,wayland libxkbcommon" |
| 49 | |
| 50 | SIMPLE_TARGET_SYS = "${@'${TARGET_SYS}'.replace('${TARGET_VENDOR}', '')}" |
| 51 | |
| 52 | EXTRA_OECONF = " \ |
| 53 | --prefix=${prefix} \ |
| 54 | --target=${SIMPLE_TARGET_SYS} \ |
| 55 | --confdir=${sysconfdir} \ |
| 56 | --datadir=${datadir} \ |
| 57 | --disable-manpage-build \ |
| 58 | --disable-gl \ |
| 59 | --disable-libsmbclient \ |
| 60 | --disable-encoding \ |
| 61 | --disable-libbluray \ |
| 62 | --disable-dvdread \ |
| 63 | --disable-dvdnav \ |
| 64 | --disable-cdda \ |
| 65 | --disable-uchardet \ |
| 66 | --disable-rubberband \ |
| 67 | --disable-lcms2 \ |
| 68 | --disable-vapoursynth \ |
| 69 | --disable-vapoursynth-lazy \ |
| 70 | ${PACKAGECONFIG_CONFARGS} \ |
| 71 | " |
| 72 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 73 | adjust_waf_perms() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 74 | chmod +x ${S}/waf |
| 75 | } |
| 76 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 77 | do_patch[postfuncs] += "adjust_waf_perms" |
| 78 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 79 | FILES_${PN} += "${datadir}/icons" |