Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "A garbage collector for C and C++" |
| 2 | |
| 3 | DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\ |
| 4 | used as a garbage collecting replacement for C malloc or C++ new. It allows\ |
| 5 | you to allocate memory basically as you normally would, without explicitly\ |
| 6 | deallocating memory that is no longer useful. The collector automatically\ |
| 7 | recycles memory when it determines that it can no longer be otherwise\ |
| 8 | accessed.\ |
| 9 | The collector is also used by a number of programming language\ |
| 10 | implementations that either use C as intermediate code, want to facilitate\ |
| 11 | easier interoperation with C libraries, or just prefer the simple collector\ |
| 12 | interface.\ |
| 13 | Alternatively, the garbage collector may be used as a leak detector for C\ |
| 14 | or C++ programs, though that is not its primary goal.\ |
| 15 | Empirically, this collector works with most unmodified C programs, simply\ |
| 16 | by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\ |
| 17 | calls, and removing free calls." |
| 18 | |
| 19 | HOMEPAGE = "http://www.hboehm.info/gc/" |
| 20 | SECTION = "devel" |
| 21 | LICENSE = "MIT" |
| 22 | LIC_FILES_CHKSUM = "file://README.QUICK;md5=81b447d779e278628c843aef92f088fa" |
| 23 | |
| 24 | SRCREV = "d3dede3ce4462cd82a15f161af797ca51654546a" |
| 25 | SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=release-8_0 \ |
| 26 | " |
| 27 | |
| 28 | FILES_${PN}-doc = "${datadir}" |
| 29 | |
| 30 | S = "${WORKDIR}/git" |
| 31 | |
| 32 | ARM_INSTRUCTION_SET = "arm" |
| 33 | |
| 34 | inherit autotools pkgconfig |
| 35 | |
| 36 | # by default use external libatomic-ops |
| 37 | PACKAGECONFIG ??= "libatomic-ops" |
| 38 | PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops" |
| 39 | |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 40 | EXTRA_OECONF += "--enable-cpluscplus" |
| 41 | |
| 42 | CFLAGS_append_libc-musl = " -D_GNU_SOURCE -DNO_GETCONTEXT -DSEARCH_FOR_DATA_START -DUSE_MMAP -DHAVE_DL_ITERATE_PHDR" |
| 43 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 44 | BBCLASSEXTEND = "native nativesdk" |