Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Tiny XML Library" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 4 | HOMEPAGE = "https://www.msweet.org/mxml/" |
| 5 | BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues" |
| 6 | |
| 7 | SRC_URI = "git://github.com/michaelrsweet/mxml.git" |
| 8 | SRCREV = "c7755b6992a2afdd34dde47fc9be97f1237cfded" |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit autotools |
| 12 | |
| 13 | PACKAGECONFIG ??= "threads" |
| 14 | PACKAGECONFIG[threads] = "--enable-threads,--disable-threads" |
| 15 | |
| 16 | # Package does not support out of tree builds. |
| 17 | B = "${S}" |
| 18 | |
| 19 | # MXML uses autotools but it explicitly states it does not support autoheader. |
| 20 | EXTRA_AUTORECONF = "--exclude=autopoint,autoheader" |
| 21 | |
| 22 | do_configure_prepend() { |
| 23 | # Respect optimization CFLAGS specified by OE. |
| 24 | sed -e 's/-Os -g//' -i ${S}/configure.ac |
| 25 | |
| 26 | # Enable verbose compilation output. This is required for extra QA checks to work. |
| 27 | sed -e '/.SILENT:/d' -i ${S}/Makefile.in |
| 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | # Package uses DSTROOT instread of standard DESTDIR to specify install location. |
| 32 | oe_runmake install DSTROOT=${D} |
| 33 | } |