Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | SUMMARY = "Library for interfacing with common SoC peripherals" |
| 2 | DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \ |
| 3 | found in SoC (System on Chips) through generic Linux Kernel interfaces." |
| 4 | |
| 5 | HOMEPAGE = "https://github.com/jackmitch/libsoc" |
| 6 | |
| 7 | LICENSE = "LGPLv2.1" |
| 8 | LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5" |
| 9 | |
| 10 | inherit autotools pkgconfig python-dir |
| 11 | |
| 12 | SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb" |
| 13 | SRC_URI = "git://github.com/jackmitch/libsoc.git" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | BOARD ??= "devboard" |
| 18 | |
| 19 | PACKAGECONFIG ?= "" |
| 20 | |
| 21 | PACKAGECONFIG[disabledebug] = "--disable-debug,," |
| 22 | PACKAGECONFIG[allboardconfigs] = "--with-board-configs,," |
| 23 | PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},," |
| 24 | PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}" |
| 25 | |
| 26 | PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \ |
| 27 | '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}" |
| 28 | |
| 29 | RDEPENDS_${PN} = "libgcc" |
| 30 | |
| 31 | FILES_${PYTHON_PN}-libsoc-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*/*.a" |
| 32 | FILES_${PYTHON_PN}-libsoc += "${PYTHON_SITEPACKAGES_DIR}" |