blob: 185ea11b074df08186938a25e1d1493a5180f0c9 [file] [log] [blame]
Brad Bishop2f973922019-11-11 07:58:48 -05001SUMMARY = "A client-side C library implementing the SSH2 protocol"
2HOMEPAGE = "http://www.libssh2.org/"
3SECTION = "libs"
4
5DEPENDS = "zlib"
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
9
Brad Bishop996bc452019-12-02 13:05:15 -050010SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \
11 file://CVE-2019-17498.patch \
12"
Brad Bishop2f973922019-11-11 07:58:48 -050013SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927"
14SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd"
15
16inherit autotools pkgconfig
17
18EXTRA_OECONF += "\
19 --with-libz \
20 --with-libz-prefix=${STAGING_LIBDIR} \
21 "
22
23# only one of openssl and gcrypt could be set
24PACKAGECONFIG ??= "openssl"
25PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_LIBDIR}, , openssl"
26PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt"
27
28BBCLASSEXTEND = "native"