blob: fbd008c13deda07b4c922969b7db25e8f1075072 [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001SUMMARY = "Library for building powerful interactive command lines in Python"
2DESCRIPTION = "Measures the displayed width of unicode strings in a terminal"
3HOMEPAGE = "https://github.com/jquast/wcwidth"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb"
6
Patrick Williams864cc432023-02-09 14:54:44 -06007SRC_URI[sha256sum] = "a5220780a404dbe3353789870978e472cfe477761f06ee55077256e509b156d0"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06008
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN}-ptest += " \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060016 ${PYTHON_PN}-pytest \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050017 ${PYTHON_PN}-unittest-automake-output \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060018"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050022 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
Andrew Geissler6ce62a22020-11-30 19:58:47 -060023}
24
25BBCLASSEXTEND = "native nativesdk"