Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 1 | SUMMARY = "Boot performance graphing tool" |
| 2 | DESCRIPTION = "For systemd-bootchart, several proc debug interfaces are required in the kernel config: \ |
| 3 | CONFIG_SCHEDSTATS \ |
| 4 | below is optional, for additional info: \ |
| 5 | CONFIG_SCHED_DEBUG" |
| 6 | HOMEPAGE = "https://github.com/systemd/systemd-bootchart" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 7 | LICENSE = "LGPLv2.1 & GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 9 | file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe" |
| 10 | |
| 11 | SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | file://0001-architecture-Recognise-RISCV-32-RISCV-64.patch \ |
| 13 | file://mips64.patch \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 14 | file://no_lto.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | SRC_URI_append_libc-musl = " \ |
| 18 | file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \ |
| 19 | file://0002-musl-does-not-provide-printf-h.patch \ |
| 20 | file://0003-musl-does-not-provide-canonicalize_file_name.patch \ |
| 21 | " |
| 22 | |
| 23 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 24 | SRCREV = "8183cfd9dad8beca5434d625cf6b2df87775e956" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool" |
| 29 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 30 | inherit pkgconfig autotools systemd features_check |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 31 | |
| 32 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 33 | |
| 34 | SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service" |
| 35 | |
| 36 | do_configure_prepend() { |
| 37 | # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot |
| 38 | rm -f ${S}/m4/intltool.m4 |
| 39 | } |
| 40 | |
| 41 | FILES_${PN} += "${systemd_unitdir}/systemd-bootchart" |
| 42 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 43 | EXTRA_OECONF = " --with-rootprefix=${root_prefix} \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 44 | --with-rootlibdir=${base_libdir}" |