George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 1 | PR = "r1" |
| 2 | LICENSE = "Apache-2.0 & BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10 \ |
| 4 | file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \ |
| 5 | " |
| 6 | |
| 7 | inherit systemd |
| 8 | inherit obmc-phosphor-systemd |
| 9 | |
| 10 | |
| 11 | DEPENDS += "systemd" |
| 12 | DEPENDS += "phosphor-ipmi-flash" |
| 13 | RDEPENDS_${PN} += "bash" |
| 14 | |
| 15 | SRC_URI += " file://bios-verify.sh \ |
| 16 | file://bios-update.sh \ |
| 17 | file://phosphor-ipmi-flash-bios-verify.service \ |
| 18 | file://phosphor-ipmi-flash-bios-update.service \ |
| 19 | file://config-bios.json \ |
| 20 | " |
| 21 | |
| 22 | FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json" |
| 23 | |
| 24 | do_install() { |
| 25 | install -d ${D}${bindir} |
| 26 | install -m 0755 ${WORKDIR}/bios-verify.sh ${D}${bindir}/ |
| 27 | install -m 0755 ${WORKDIR}/bios-update.sh ${D}${bindir}/ |
| 28 | |
| 29 | install -d ${D}${systemd_system_unitdir} |
| 30 | install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-verify.service ${D}${systemd_system_unitdir} |
| 31 | install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service ${D}${systemd_system_unitdir} |
| 32 | |
| 33 | install -d ${D}${datadir}/phosphor-ipmi-flash |
| 34 | install -m 0644 ${WORKDIR}/config-bios.json ${D}${datadir}/phosphor-ipmi-flash |
| 35 | } |
| 36 | |
| 37 | |
| 38 | SYSTEMD_PACKAGES = "${PN}" |
| 39 | SYSTEMD_SERVICE_${PN} = "phosphor-ipmi-flash-bios-verify.service phosphor-ipmi-flash-bios-update.service" |