Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Project parser generator (yacc replacement)" |
| 2 | DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \ |
| 3 | an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \ |
| 4 | grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \ |
| 5 | little trouble." |
| 6 | HOMEPAGE = "http://www.gnu.org/software/bison/" |
| 7 | LICENSE = "GPLv3" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 9 | SECTION = "devel" |
| 10 | DEPENDS = "bison-native flex-native" |
| 11 | |
| 12 | SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | file://add-with-bisonlocaledir.patch \ |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 14 | " |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "a3b5813f48a11e540ef26f46e4d288c0c25c7907d9879ae50e430ec49f63c010" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
| 17 | # No point in hardcoding path to m4, just use PATH |
| 18 | EXTRA_OECONF += "M4=m4" |
| 19 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | inherit autotools gettext texinfo |
| 21 | |
| 22 | # The automatic m4 path detection gets confused, so force the right value |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 23 | acpaths = "-I ./m4" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | |
| 25 | do_compile_prepend() { |
| 26 | for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done |
| 27 | } |
| 28 | |
| 29 | do_install_append_class-native() { |
| 30 | create_wrapper ${D}/${bindir}/bison \ |
| 31 | BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison |
| 32 | } |
| 33 | do_install_append_class-nativesdk() { |
| 34 | create_wrapper ${D}/${bindir}/bison \ |
| 35 | BISON_PKGDATADIR=${datadir}/bison |
| 36 | } |
| 37 | BBCLASSEXTEND = "native nativesdk" |