Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Ninja is a small build system with a focus on speed." |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://ninja-build.org/" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e" |
| 5 | |
| 6 | DEPENDS = "re2c-native ninja-native" |
| 7 | |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 8 | SRCREV = "a1f879b29c9aafe6a2bc0ba885701f8f4f19f772" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release" |
| 11 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | do_configure[noexec] = "1" |
| 16 | |
| 17 | do_compile_class-native() { |
| 18 | python3 ./configure.py --bootstrap |
| 19 | } |
| 20 | |
| 21 | do_compile() { |
| 22 | python3 ./configure.py |
| 23 | ninja |
| 24 | } |
| 25 | |
| 26 | do_install() { |
| 27 | install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja |
| 28 | } |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |