Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Powerful Python library for atomic file writes" |
| 2 | HOMEPAGE = "https://github.com/untitaker/python-atomicwrites" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=91cc36cfafeefb7863673bcfcb1d4da4" |
| 5 | |
| 6 | SRC_URI[md5sum] = "b5cc15c8f9f180a48665f9aacf91d817" |
| 7 | SRC_URI[sha256sum] = "ae70396ad1a434f9c7046fd2dd196fc04b12f9e91ffb859164193be8b6168a7a" |
| 8 | |
| 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
| 15 | RDEPENDS_${PN}-ptest += " \ |
| 16 | ${PYTHON_PN}-pytest \ |
| 17 | ${PYTHON_PN}-unixadmin \ |
| 18 | " |
| 19 | |
| 20 | do_install_ptest() { |
| 21 | install -d ${D}${PTEST_PATH}/tests |
| 22 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 23 | } |
| 24 | |
| 25 | RDEPENDS_${PN} = "${PYTHON_PN}-misc" |