Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Performance analysis tools for Linux" |
| 2 | DESCRIPTION = "Performance counters for Linux are a new kernel-based \ |
| 3 | subsystem that provide a framework for all things \ |
| 4 | performance analysis. It covers hardware level \ |
| 5 | (CPU/PMU, Performance Monitoring Unit) features \ |
| 6 | and software features (software counters, tracepoints) \ |
| 7 | as well." |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 8 | HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | |
| 10 | LICENSE = "GPLv2" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
| 12 | PR = "r9" |
| 13 | |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 14 | PACKAGECONFIG ??= "scripting tui libunwind" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | PACKAGECONFIG[dwarf] = ",NO_DWARF=1" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 16 | PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | # gui support was added with kernel 3.6.35 |
| 18 | # since 3.10 libnewt was replaced by slang |
| 19 | # to cover a wide range of kernel we add both dependencies |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 20 | PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang" |
| 21 | PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind" |
| 22 | PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1" |
| 23 | PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap" |
| 24 | PACKAGECONFIG[jvmti] = ",NO_JVMTI=1" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 25 | # libaudit support would need scripting to be enabled |
| 26 | PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native" |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 28 | PACKAGECONFIG[cap] = ",,libcap" |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 29 | # Arm CoreSight |
| 30 | PACKAGECONFIG[coresight] = "CORESIGHT=1,,opencsd" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | |
| 32 | # libunwind is not yet ported for some architectures |
| 33 | PACKAGECONFIG_remove_arc = "libunwind" |
| 34 | PACKAGECONFIG_remove_riscv64 = "libunwind" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 36 | DEPENDS = " \ |
| 37 | virtual/${MLPREFIX}libc \ |
| 38 | ${MLPREFIX}elfutils \ |
| 39 | ${MLPREFIX}binutils \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 40 | bison-native flex-native xz \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 41 | " |
| 42 | |
| 43 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |
| 44 | |
| 45 | PROVIDES = "virtual/perf" |
| 46 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 47 | inherit linux-kernel-base kernel-arch manpages |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 48 | |
| 49 | # needed for building the tools/perf Python bindings |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 50 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3native', '', d)} |
| 51 | inherit python3-dir |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 52 | export PYTHON_SITEPACKAGES_DIR |
| 53 | |
| 54 | #kernel 3.1+ supports WERROR to disable warnings as errors |
| 55 | export WERROR = "0" |
| 56 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 57 | do_populate_lic[depends] += "virtual/kernel:do_shared_workdir" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 58 | |
| 59 | # needed for building the tools/perf Perl binding |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 60 | include ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perf-perl.inc', '', d)} |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 61 | |
| 62 | inherit kernelsrc |
| 63 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 64 | S = "${WORKDIR}/${BP}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 65 | SPDX_S = "${S}/tools/perf" |
| 66 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 67 | # The LDFLAGS is required or some old kernels fails due missing |
| 68 | # symbols and this is preferred than requiring patches to every old |
| 69 | # supported kernel. |
| 70 | LDFLAGS="-ldl -lutil" |
| 71 | |
| 72 | EXTRA_OEMAKE = '\ |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 73 | V=1 \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 74 | -C ${S}/tools/perf \ |
| 75 | O=${B} \ |
| 76 | CROSS_COMPILE=${TARGET_PREFIX} \ |
| 77 | ARCH=${ARCH} \ |
| 78 | CC="${CC}" \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 79 | CCLD="${CC}" \ |
| 80 | LDSHARED="${CC} -shared" \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 81 | AR="${AR}" \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 82 | LD="${LD}" \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 83 | EXTRA_CFLAGS="-ldw" \ |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 84 | EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 85 | perfexecdir=${libexecdir} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 86 | NO_GTK2=1 \ |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 87 | ${PACKAGECONFIG_CONFARGS} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 88 | TMPDIR="${B}" \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 89 | LIBUNWIND_DIR=${STAGING_EXECPREFIXDIR} \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 90 | ' |
| 91 | |
| 92 | EXTRA_OEMAKE += "\ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 93 | 'DESTDIR=${D}' \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 94 | 'prefix=${prefix}' \ |
| 95 | 'bindir=${bindir}' \ |
| 96 | 'sharedir=${datadir}' \ |
| 97 | 'sysconfdir=${sysconfdir}' \ |
| 98 | 'perfexecdir=${libexecdir}/perf-core' \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 99 | 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \ |
| 100 | 'sharedir=${@os.path.relpath(datadir, prefix)}' \ |
| 101 | 'mandir=${@os.path.relpath(mandir, prefix)}' \ |
| 102 | 'infodir=${@os.path.relpath(infodir, prefix)}' \ |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 103 | ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'PYTHON=python3 PYTHON_CONFIG=python3-config', '', d)} \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 104 | " |
| 105 | |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 106 | # During do_configure, we might run a 'make clean'. That often breaks |
| 107 | # when done in parallel, so disable parallelism for do_configure. Note |
| 108 | # that it has to be done this way rather than by passing -j1, since |
| 109 | # perf's build system by default ignores any -j argument, but does |
| 110 | # honour a JOBS variable. |
| 111 | EXTRA_OEMAKE_append_task-configure = " JOBS=1" |
| 112 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 113 | PERF_SRC ?= "Makefile \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 114 | tools/arch \ |
| 115 | tools/build \ |
| 116 | tools/include \ |
| 117 | tools/lib \ |
| 118 | tools/Makefile \ |
| 119 | tools/perf \ |
| 120 | tools/scripts \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 121 | scripts/ \ |
| 122 | arch/${ARCH}/Makefile \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 123 | " |
| 124 | |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 125 | PERF_EXTRA_LDFLAGS = "" |
| 126 | |
| 127 | # MIPS N32 |
| 128 | PERF_EXTRA_LDFLAGS_mipsarchn32eb = "-m elf32btsmipn32" |
| 129 | PERF_EXTRA_LDFLAGS_mipsarchn32el = "-m elf32ltsmipn32" |
| 130 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 131 | do_compile() { |
| 132 | # Linux kernel build system is expected to do the right thing |
| 133 | unset CFLAGS |
| 134 | oe_runmake all |
| 135 | } |
| 136 | |
| 137 | do_install() { |
| 138 | # Linux kernel build system is expected to do the right thing |
| 139 | unset CFLAGS |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 140 | oe_runmake install |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 141 | # we are checking for this make target to be compatible with older perf versions |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 142 | if ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 143 | oe_runmake DESTDIR=${D} install-python_ext |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 144 | fi |
| 145 | } |
| 146 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 147 | do_configure[prefuncs] += "copy_perf_source_from_kernel" |
| 148 | python copy_perf_source_from_kernel() { |
| 149 | sources = (d.getVar("PERF_SRC") or "").split() |
| 150 | src_dir = d.getVar("STAGING_KERNEL_DIR") |
| 151 | dest_dir = d.getVar("S") |
| 152 | bb.utils.mkdirhier(dest_dir) |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 153 | bb.utils.prunedir(dest_dir) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 154 | for s in sources: |
| 155 | src = oe.path.join(src_dir, s) |
| 156 | dest = oe.path.join(dest_dir, s) |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 157 | if not os.path.exists(src): |
| 158 | bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 159 | if os.path.isdir(src): |
| 160 | oe.path.copyhardlinktree(src, dest) |
| 161 | else: |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 162 | src_path = os.path.dirname(s) |
| 163 | os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 164 | bb.utils.copyfile(src, dest) |
| 165 | } |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 166 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 167 | do_configure_prepend () { |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 168 | # If building a multlib based perf, the incorrect library path will be |
| 169 | # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 170 | # build, with a 64 bit multilib, the arch won't match and the detection of a |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 171 | # 64 bit build (and library) are not exected. To ensure that libraries are |
| 172 | # installed to the correct location, we can use the weak assignment in the |
| 173 | # config/Makefile. |
| 174 | # |
| 175 | # Also need to relocate .config-detected to $(OUTPUT)/config-detected |
| 176 | # for kernel sources that do not already do this |
| 177 | # as two builds (e.g. perf and lib32-perf from mutlilib can conflict |
| 178 | # with each other if its in the shared source directory |
| 179 | # |
| 180 | if [ -e "${S}/tools/perf/config/Makefile" ]; then |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 181 | perfconfig="${S}/tools/perf/config/Makefile" |
| 182 | fi |
| 183 | if [ -e "${S}/tools/perf/Makefile.config" ]; then |
| 184 | perfconfig="${S}/tools/perf/Makefile.config" |
| 185 | fi |
| 186 | if [ -n "${perfconfig}" ]; then |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 187 | # Match $(prefix)/$(lib) and $(prefix)/lib |
| 188 | sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \ |
| 189 | -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \ |
| 190 | -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 191 | ${perfconfig} |
| 192 | fi |
| 193 | # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)" |
| 194 | # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it |
| 195 | # will use the relative path 'share/man', in the way it will resulting in |
| 196 | # incorrect installation for man pages. |
| 197 | if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then |
| 198 | sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 199 | fi |
| 200 | if [ -e "${S}/tools/perf/Makefile.perf" ]; then |
| 201 | sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ |
| 202 | ${S}/tools/perf/Makefile.perf |
| 203 | sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \ |
| 204 | ${S}/tools/perf/Makefile.perf |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 205 | # backport https://github.com/torvalds/linux/commit/e4ffd066ff440a57097e9140fa9e16ceef905de8 |
| 206 | sed -i -e 's,\($(Q)$(SHELL) .$(arch_errno_tbl).\) $(CC) $(arch_errno_hdr_dir),\1 $(firstword $(CC)) $(arch_errno_hdr_dir),g' \ |
| 207 | ${S}/tools/perf/Makefile.perf |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 208 | fi |
| 209 | sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \ |
Patrick Williams | d7e9631 | 2015-09-22 08:09:05 -0500 | [diff] [blame] | 210 | ${S}/tools/perf/Makefile* |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 211 | |
| 212 | if [ -e "${S}/tools/build/Makefile.build" ]; then |
| 213 | sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ |
| 214 | ${S}/tools/build/Makefile.build |
| 215 | fi |
| 216 | |
| 217 | # We need to ensure the --sysroot option in CC is preserved |
| 218 | if [ -e "${S}/tools/perf/Makefile.perf" ]; then |
| 219 | sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf |
| 220 | sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 221 | sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 222 | fi |
| 223 | if [ -e "${S}/tools/lib/api/Makefile" ]; then |
| 224 | sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile |
| 225 | sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 226 | sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 227 | fi |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 228 | if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then |
| 229 | sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile |
| 230 | sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile |
| 231 | fi |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 232 | if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then |
| 233 | sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile |
| 234 | fi |
| 235 | if [ -e "${S}/tools/build/Makefile.feature" ]; then |
| 236 | sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature |
| 237 | fi |
| 238 | |
| 239 | # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include |
| 240 | if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then |
| 241 | sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c |
| 242 | fi |
| 243 | if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then |
| 244 | sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c |
| 245 | sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c |
| 246 | fi |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 247 | |
| 248 | # use /usr/bin/env instead of version specific python |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 249 | for s in `find ${S}/tools/perf/ -name '*.py'` `find ${S}/scripts/ -name 'bpf_helpers_doc.py'`; do |
| 250 | sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${s} |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 251 | done |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 252 | |
| 253 | # unistd.h can be out of sync between libc-headers and the captured version in the perf source |
| 254 | # so we copy it from the sysroot unistd.h to the perf unistd.h |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 255 | install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 256 | install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 257 | } |
| 258 | |
| 259 | python do_package_prepend() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 260 | d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0]) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 261 | } |
| 262 | |
| 263 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 264 | |
| 265 | |
| 266 | PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python" |
| 267 | |
| 268 | RDEPENDS_${PN} += "elfutils bash" |
| 269 | RDEPENDS_${PN}-archive =+ "bash" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 270 | RDEPENDS_${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python3', '', d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 271 | RDEPENDS_${PN}-perl =+ "bash perl perl-modules" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 272 | RDEPENDS_${PN}-tests =+ "python3" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 273 | |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 274 | RSUGGESTS_SCRIPTING = "${@bb.utils.contains('PACKAGECONFIG', 'scripting', '${PN}-perl ${PN}-python', '',d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 275 | RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}" |
| 276 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 277 | FILES_SOLIBSDEV = "" |
| 278 | FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent ${libdir}/libperf-jvmti.so" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 279 | FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 280 | FILES_${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 281 | FILES_${PN}-python = " \ |
| 282 | ${PYTHON_SITEPACKAGES_DIR} \ |
| 283 | ${libexecdir}/perf-core/scripts/python \ |
| 284 | " |
| 285 | FILES_${PN}-perl = "${libexecdir}/perf-core/scripts/perl" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 286 | |
| 287 | |
| 288 | INHIBIT_PACKAGE_DEBUG_SPLIT="1" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 289 | DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized" |