Mike Garrett | c088ff2 | 2021-08-27 16:59:09 -0500 | [diff] [blame] | 1 | SUMMARY = "Enable Host Boot" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${HPEBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
| 5 | |
| 6 | inherit obmc-phosphor-systemd |
| 7 | |
| 8 | HOST_BOOT_SERVICE = "host-boot-enable.service" |
| 9 | SYSTEMD_SERVICE:${PN} += "${HOST_BOOT_SERVICE}" |
| 10 | |
| 11 | HOST_BOOT_FMT = "../${HOST_BOOT_SERVICE}:multi-user.target.wants/${HOST_BOOT_SERVICE}" |
| 12 | SYSTEMD_LINK_${PN} += "${HOST_BOOT_FMT}" |
| 13 | |
| 14 | SRC_URI += "file://host-boot-enable.service" |
| 15 | SRC_URI += "file://host-boot-enable.sh" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${bindir} |
| 19 | install -m 0755 ${WORKDIR}/host-boot-enable.sh ${D}${bindir} |
| 20 | } |