Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Unprivileged sandboxing tool" |
| 2 | HOMEPAGE = "https://github.com/containers/bubblewrap" |
| 3 | LICENSE = "LGPL-2.0-or-later" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 5 | |
| 6 | DEPENDS = "libcap" |
| 7 | |
| 8 | SRC_URI = "https://github.com/containers/${BPN}/releases/download/v${PV}/${BP}.tar.xz" |
| 9 | SRC_URI[sha256sum] = "8a0ec802d1b3e956c5bb0a40a81c9ce0b055a31bf30a8efa547433603b8af20b" |
| 10 | |
| 11 | UPSTREAM_CHECK_URI = "https://github.com/containers/bubblewrap/releases" |
| 12 | UPSTREAM_CHECK_REGEX = "bubblewrap-(?P<pver>\d+(\.\d+)+)\.tar" |
| 13 | |
| 14 | inherit autotools bash-completion manpages pkgconfig |
| 15 | |
| 16 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}" |
| 17 | PACKAGECONFIG[manpages] = "--enable-man,--disable-man,libxslt-native docbook-xsl-stylesheets-native xmlto-native" |
| 18 | PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux" |
| 19 | PACKAGECONFIG[setuid] = "--with-priv-mode=setuid,--with-priv-mode=none" |
| 20 | |
| 21 | PACKAGES += "${PN}-zsh-completion" |
| 22 | |
| 23 | FILES:${PN}-zsh-completion = "${datadir}/zsh/site-functions" |