Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | # Copyright (C) 2018 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "rpcsvc protocol definitions from glibc" |
| 5 | |
| 6 | DESCRIPTION = "This package contains rpcsvc proto.x files from glibc, which are\ |
| 7 | missing in libtirpc. Additional it contains rpcgen, which is needed\ |
| 8 | to create header files and sources from protocol files.\ |
| 9 | This package is only needed, if glibc is installed without the\ |
| 10 | deprecated sunrpc functionality and libtirpc should replace it." |
| 11 | |
| 12 | HOMEPAGE = "https://github.com/thkukuk/rpcsvc-proto" |
| 13 | LICENSE = "BSD-3-Clause" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=0daaf958d5531ab86169ec6e275e1517" |
| 15 | SECTION = "libs" |
| 16 | DEPENDS += "rpcsvc-proto-native" |
| 17 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 18 | PV = "1.4.3" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 20 | SRCREV = "71e0a12c04d130a78674ac6309eefffa6ecee612" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 22 | SRC_URI = "git://github.com/thkukuk/${BPN};branch=master;protocol=https \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | file://0001-Use-cross-compiled-rpcgen.patch \ |
| 24 | " |
| 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 28 | inherit autotools gettext |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | EXTRA_OEMAKE:class-native = " -C rpcgen" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | do_configure:prepend() { |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 33 | touch ${S}/ABOUT-NLS |
| 34 | } |
| 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | do_install:append() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 37 | # They come from quota recipe |
| 38 | rm -rf ${D}${includedir}/rpcsvc/rquota.[hx] |
| 39 | } |
| 40 | |
| 41 | BBCLASSEXTEND += "native nativesdk" |