Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "XCB: The X protocol C binding library" |
| 2 | DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \ |
| 3 | for Xlib featuring a small footprint, latency hiding, direct access to \ |
| 4 | the protocol, improved threading support, and extensibility." |
| 5 | HOMEPAGE = "http://xcb.freedesktop.org" |
| 6 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB" |
| 7 | SECTION = "x11/libs" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7" |
| 11 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 12 | SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.xz" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "cc38744f817cf6814c847e2df37fcb8997357d72fa4bcbc228ae0fe47219a059" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | |
| 16 | BBCLASSEXTEND = "native nativesdk" |
| 17 | |
| 18 | DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp" |
| 19 | |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 20 | PACKAGES_DYNAMIC = "^${PN}-.*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | FILES:${PN} = "${libdir}/libxcb.so.*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 24 | inherit autotools pkgconfig features_check |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | |
| 26 | # The libxau and others requires x11 in DISTRO_FEATURES |
| 27 | REQUIRED_DISTRO_FEATURES = "x11" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | |
| 29 | export PYTHON = "python3" |
| 30 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | do_install:append () { |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 32 | chown root.root ${D}${datadir}/doc/${BPN}/tutorial -R |
| 33 | } |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | python populate_packages:prepend () { |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 36 | do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', '${PN}-%s', 'XCB library module for %s', allow_links=True) |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | } |