blob: 339bb35f2dc72150742bdb7fd927a1bc87d04818 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Utility that provides userspace support for reading and writing to the i.MX fuses"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=201414b6610203caed355323b1ab3116"
4
5GO_IMPORT = "github.com/usbarmory/crucible"
6SRC_URI = "git://${GO_IMPORT}.git;protocol=https;branch=master"
7
8GO_INSTALL = "\
9 ${GO_IMPORT}/cmd/crucible \
10 ${GO_IMPORT}/cmd/habtool \
11"
12SRCREV = "358b5e7adb7f101f870f2b42fe5371460a3cccb6"
13
14# Workaround for network access issue during compile step.
15# This needs to be fixed in the recipes buildsystem so that
16# it can be accomplished during do_fetch task.
17do_compile[network] = "1"
18
19inherit go-mod