Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 1 | SUMMARY = "FastCGI wrapper for CGI scripts" |
| 2 | DESCRIPTION = "FcgiWrap is a simple server for running CGI applications over FastCGI. Fcgiwrap can be used together with Nginx to serve CGI or Perl scripts" |
| 3 | HOMEPAGE = "https://github.com/gnosek/fcgiwrap" |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=a95d02d614a3a0232d4e6e51b7963c5b" |
| 7 | |
| 8 | DEPENDS = "fcgi" |
| 9 | |
| 10 | SRC_URI = "git://github.com/gnosek/fcgiwrap.git;protocol=https;branch=${BRANCH} \ |
| 11 | file://0001-Fix-implicit-fallthrough-warning.patch \ |
| 12 | " |
| 13 | BRANCH = "master" |
| 14 | SRCREV = "99c942c90063c73734e56bacaa65f947772d9186" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | CFLAGS =+ "-I${B}" |
| 18 | EXTRA_OEMAKE = "VPATH=${S}" |
| 19 | |
| 20 | inherit autotools pkgconfig |
| 21 | |
| 22 | do_install() { |
| 23 | install -Dm 755 ${B}/fcgiwrap ${D}${sbindir}/fcgiwrap |
| 24 | } |