Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager." |
| 2 | SUMMARY = "EFI Boot Manager" |
| 3 | HOMEPAGE = "https://github.com/rhinstaller/efibootmgr" |
| 4 | SECTION = "base" |
| 5 | |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
| 8 | |
| 9 | DEPENDS = "pciutils zlib efivar" |
| 10 | |
| 11 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 12 | |
| 13 | SRCREV = "e067160ecef8208e1944002e5d50b275733211fb" |
| 14 | SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \ |
| 15 | file://0001-remove-extra-decl.patch \ |
| 16 | " |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit pkgconfig |
| 20 | |
| 21 | EXTRA_OEMAKE = "'EFIDIR=/' 'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar`'" |
| 22 | |
| 23 | CFLAGS_append_toolchain-clang = " -Wno-error" |
| 24 | do_install () { |
| 25 | install -D -p -m0755 ${B}/src/efibootmgr ${D}/${sbindir}/efibootmgr |
| 26 | } |
| 27 | |
| 28 | CLEANBROKEN = "1" |