Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Manage plain dm-crypt and LUKS encrypted volumes" |
| 2 | DESCRIPTION = "Cryptsetup is used to conveniently setup dm-crypt managed \ |
| 3 | device-mapper mappings. These include plain dm-crypt volumes and \ |
| 4 | LUKS volumes. The difference is that LUKS uses a metadata header \ |
| 5 | and can hence offer more features than plain dm-crypt. On the other \ |
| 6 | hand, the header is visible and vulnerable to damage." |
| 7 | HOMEPAGE = "https://gitlab.com/cryptsetup/cryptsetup" |
| 8 | SECTION = "console" |
| 9 | LICENSE = "GPL-2.0-with-OpenSSL-exception" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=32107dd283b1dfeb66c9b3e6be312326" |
| 11 | |
| 12 | DEPENDS = "util-linux libdevmapper popt libgcrypt json-c" |
| 13 | |
| 14 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}/${BP}.tar.xz" |
| 15 | SRC_URI[md5sum] = "41d8b985ef69242852b93e95d53e8e28" |
| 16 | SRC_URI[sha256sum] = "a3eeb2741f8f3376d16585191f3c60e067dd987e096c3c4b073fab7748b1c897" |
| 17 | |
| 18 | inherit autotools gettext pkgconfig |
| 19 | |
| 20 | # Use openssl because libgcrypt drops root privileges |
| 21 | # if libgcrypt is linked with libcap support |
| 22 | PACKAGECONFIG ??= "openssl" |
| 23 | PACKAGECONFIG[openssl] = "--with-crypto_backend=openssl,,openssl" |
| 24 | PACKAGECONFIG[gcrypt] = "--with-crypto_backend=gcrypt,,libgcrypt" |
| 25 | |
| 26 | RRECOMMENDS_${PN} = "kernel-module-aes-generic \ |
| 27 | kernel-module-dm-crypt \ |
| 28 | kernel-module-md5 \ |
| 29 | kernel-module-cbc \ |
| 30 | kernel-module-sha256-generic \ |
| 31 | kernel-module-xts \ |
| 32 | " |
| 33 | |
| 34 | EXTRA_OECONF = "--enable-static" |
| 35 | |
| 36 | FILES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','systemd','${exec_prefix}/lib/tmpfiles.d/cryptsetup.conf', '', d)}" |
| 37 | |
| 38 | BBCLASSEXTEND = "native nativesdk" |