Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A parallel implementation of gzip" |
| 2 | DESCRIPTION = "pigz, which stands for parallel implementation of gzip, is a \ |
| 3 | fully functional replacement for gzip that exploits multiple processors and \ |
| 4 | multiple cores to the hilt when compressing data. pigz was written by Mark \ |
| 5 | Adler, and uses the zlib and pthread libraries." |
| 6 | HOMEPAGE = "http://zlib.net/pigz/" |
| 7 | SECTION = "console/utils" |
| 8 | LICENSE = "Zlib & Apache-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://pigz.c;md5=9ae6dee8ceba9610596ed0ada493d142;beginline=7;endline=21" |
| 10 | |
| 11 | SRC_URI = "http://zlib.net/${BPN}/fossils/${BP}.tar.gz" |
| 12 | SRC_URI[md5sum] = "def2f6e19d9d8231445adc1349d346df" |
| 13 | SRC_URI[sha256sum] = "a4f816222a7b4269bd232680590b579ccc72591f1bb5adafcd7208ca77e14f73" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 14 | PROVIDES_class-native += "gzip-native" |
| 15 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | # Point this at the homepage in case /fossils/ isn't updated |
| 17 | UPSTREAM_CHECK_URI = "http://zlib.net/${BPN}/" |
| 18 | UPSTREAM_CHECK_REGEX = "pigz-(?P<pver>.*)\.tar" |
| 19 | |
| 20 | DEPENDS = "zlib" |
| 21 | |
| 22 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 23 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 24 | inherit update-alternatives |
| 25 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 26 | do_install() { |
| 27 | # Install files into /bin (FHS), which is typical place for gzip |
| 28 | install -d ${D}${base_bindir} |
| 29 | install ${B}/pigz ${D}${base_bindir}/pigz |
| 30 | ln -nsf pigz ${D}${base_bindir}/unpigz |
| 31 | ln -nsf pigz ${D}${base_bindir}/pigzcat |
| 32 | } |
| 33 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 34 | do_install_append_class-native() { |
| 35 | install -d ${D}${bindir} |
| 36 | install ${B}/pigz ${D}${bindir}/gzip |
| 37 | ln -nsf gzip ${D}${bindir}/gunzip |
| 38 | ln -nsf gzip ${D}${bindir}/zcat |
| 39 | } |
| 40 | |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 41 | ALTERNATIVE_PRIORITY = "110" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 42 | ALTERNATIVE_${PN} = "gunzip gzip zcat" |
| 43 | ALTERNATIVE_${PN}_class-nativesdk = "" |
| 44 | ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip" |
| 45 | ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip" |
| 46 | ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat" |
| 47 | ALTERNATIVE_TARGET = "${base_bindir}/pigz" |
| 48 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 49 | BBCLASSEXTEND = "native nativesdk" |