Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "A python package implementing the crc32c algorithmin hardware and software" |
| 2 | HOMEPAGE = "https://github.com/ICRAR/crc32c" |
| 3 | |
| 4 | LICENSE = "BSD-2-Clause & BSD-3-Clause & CRC32C-ADLER & LGPL-2.0-or-later" |
| 5 | LIC_FILES_CHKSUM = " \ |
| 6 | file://LICENSE;md5=4fbd65380cdd255951079008b364516c \ |
| 7 | file://LICENSE.google-crc32c;md5=e9ed01b5e5ac9eae23fc2bb33701220c \ |
| 8 | file://LICENSE.slice-by-8;md5=6b3bc7709d6b2db6646ec2467310ff6b \ |
| 9 | file://crc32c_adler.c;startline=9;endline=24;md5=c60e6e55d0e5d95effa6fad27db0711a \ |
| 10 | " |
| 11 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "17ce6c596ad0d53df52dcd72defb66984aeabd98fbefea7ba848a6b6bdece36a" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 13 | |
| 14 | inherit pypi setuptools3 |
| 15 | |
| 16 | do_compile:prepend() { |
| 17 | if ! grep 'platform =' setup.cfg; then |
| 18 | printf "[build_ext]\nplatform = ${TARGET_ARCH}" >> setup.cfg |
| 19 | fi |
| 20 | } |
| 21 | |
| 22 | RDEPENDS:${PN} += "python3-core" |