Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # This recipe tracks the linux-yocto-dev repository as its upstream source. |
| 2 | # Since this tree is frequently updated, and periodically rebuilt, AUTOREV is |
| 3 | # used to track its contents. |
| 4 | # |
| 5 | # This recipe is just like other linux-yocto variants, with the only difference |
| 6 | # being that to avoid network access during initial parsing, static SRCREVs are |
| 7 | # provided and overridden if the preferred kernel provider is linux-yocto-dev. |
| 8 | # |
| 9 | # To enable this recipe, set PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-dev" |
| 10 | |
| 11 | inherit kernel |
| 12 | require recipes-kernel/linux/linux-yocto.inc |
| 13 | |
| 14 | # provide this .inc to set specific revisions |
| 15 | include recipes-kernel/linux/linux-yocto-dev-revisions.inc |
| 16 | |
| 17 | # Skip processing of this recipe if it is not explicitly specified as the |
| 18 | # PREFERRED_PROVIDER for virtual/kernel. This avoids network access required |
| 19 | # by the use of AUTOREV SRCREVs, which are the default for this recipe. |
| 20 | python () { |
| 21 | if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev": |
| 22 | raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it") |
| 23 | } |
| 24 | |
| 25 | KBRANCH = "standard/base" |
| 26 | KMETA = "kernel-meta" |
| 27 | |
| 28 | SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;branch=${KBRANCH};name=machine \ |
| 29 | git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=master;destsuffix=${KMETA}" |
| 30 | |
| 31 | # Set default SRCREVs. Both the machine and meta SRCREVs are statically set |
| 32 | # to the korg v3.7 tag, and hence prevent network access during parsing. If |
| 33 | # linux-yocto-dev is the preferred provider, they will be overridden to |
| 34 | # AUTOREV in following anonymous python routine and resolved when the |
| 35 | # variables are finalized. |
| 36 | SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}' |
| 37 | SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}' |
| 38 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 39 | LINUX_VERSION ?= "4.6-rc+" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 40 | LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}" |
| 41 | PV = "${LINUX_VERSION}+git${SRCPV}" |
| 42 | |
| 43 | COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64)" |
| 44 | |
| 45 | # Functionality flags |
| 46 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc" |
| 47 | KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}" |
| 48 | KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc" |
| 49 | KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc" |
| 50 | KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}" |
| 51 | |