Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 1 | SUMMARY = "Core utilities for Python packages" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/pypa/packaging" |
| 3 | LICENSE = "Apache-2.0 | BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91" |
| 5 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "a392980d2b6cffa644431898be54b0045151319d1e7ec34f0cfed48767dd334f" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 7 | |
| 8 | inherit pypi python_flit_core |
| 9 | |
| 10 | BBCLASSEXTEND = "native nativesdk" |
| 11 | |
| 12 | # Bootstrap the native build |
| 13 | DEPENDS:remove:class-native = "python3-build-native" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 14 | RDEPENDS:${PN} += "python3-profile" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 15 | |
| 16 | do_compile:class-native () { |
| 17 | python_flit_core_do_manual_build |
| 18 | } |