blob: 53d3522dd7835c565a06bfb8a48d2e6a10d2b4d3 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Core utilities for Python packages"
Andrew Geisslerc5535c92023-01-27 16:10:19 -06002HOMEPAGE = "https://github.com/pypa/packaging"
3LICENSE = "Apache-2.0 | BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
5
Patrick Williams8e7b46e2023-05-01 14:19:06 -05006SRC_URI[sha256sum] = "a392980d2b6cffa644431898be54b0045151319d1e7ec34f0cfed48767dd334f"
Andrew Geisslerc5535c92023-01-27 16:10:19 -06007
8inherit pypi python_flit_core
9
10BBCLASSEXTEND = "native nativesdk"
11
12# Bootstrap the native build
13DEPENDS:remove:class-native = "python3-build-native"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050014RDEPENDS:${PN} += "python3-profile"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060015
16do_compile:class-native () {
17 python_flit_core_do_manual_build
18}