Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | LICENSE = "LGPLv2.1 & GPLv2 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \ |
| 6 | file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \ |
| 7 | file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \ |
| 8 | " |
| 9 | |
| 10 | inherit module |
| 11 | |
| 12 | COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux' |
| 13 | |
| 14 | #https://lttng.org/files/lttng-modules/lttng-modules-2.10.7.tar.bz2 |
| 15 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 16 | file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ |
| 17 | file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ |
| 18 | file://0001-Fix-signal-Distinguish-between-kernel_siginfo-and-si.patch \ |
| 19 | file://0002-Fix-signal-Remove-SEND_SIG_FORCED-v4.20.patch \ |
| 20 | file://0003-Fix-ext4-adjust-reserved-cluster-count-when-removing.patch \ |
| 21 | file://0004-Fix-timer-instrumentation-for-RHEL-7.6.patch \ |
| 22 | file://0005-Fix-Remove-type-argument-from-access_ok-function-v5..patch \ |
| 23 | file://0006-Fix-Replace-pointer-values-with-task-tk_pid-and-rpc_.patch \ |
| 24 | file://0007-Fix-SUNRPC-Simplify-defining-common-RPC-trace-events.patch \ |
| 25 | file://0008-Fix-btrfs-Remove-fsid-metadata_fsid-fields-from-btrf.patch \ |
| 26 | file://0009-Cleanup-tp-mempool-Remove-logically-dead-code.patch \ |
| 27 | " |
| 28 | |
| 29 | SRC_URI[md5sum] = "54bd9fca61487bbec1b3fca2f2213c98" |
| 30 | SRC_URI[sha256sum] = "fe1d269bca723e8948af871c322c37d3900e647cdc5eb3efbe821e434beee44c" |
| 31 | |
| 32 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 33 | |
| 34 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 35 | |
| 36 | do_install_append() { |
| 37 | # Delete empty directories to avoid QA failures if no modules were built |
| 38 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| 39 | } |
| 40 | |
| 41 | python do_package_prepend() { |
| 42 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| 43 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| 44 | } |
| 45 | |