Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "JSON for modern C++" |
| 2 | HOMEPAGE = "https://nlohmann.github.io/json/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588" |
| 6 | |
| 7 | CVE_PRODUCT = "json-for-modern-cpp" |
| 8 | |
| 9 | SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1;protocol=https \ |
| 10 | " |
| 11 | |
| 12 | SRCREV = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake |
| 17 | |
| 18 | EXTRA_OECMAKE += "-DJSON_BuildTests=OFF" |
| 19 | |
| 20 | # nlohmann-json is a header only C++ library, so the main package will be empty. |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 21 | ALLOW_EMPTY:${PN} = "1" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 22 | RDEPENDS:${PN}-dev = "" |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |
| 25 | |
| 26 | # other packages commonly reference the file directly as "json.hpp" |
| 27 | # create symlink to allow this usage |
| 28 | do_install:append() { |
| 29 | ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp |
| 30 | } |