Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 1 | SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol" |
| 2 | HOMEPAGE = "http://www.libssh.org" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "LGPL-2.1-only" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0" |
| 6 | |
| 7 | DEPENDS = "zlib openssl" |
| 8 | |
| 9 | SRC_URI = "git://git.libssh.org/projects/libssh.git;protocol=https;branch=stable-0.10 \ |
| 10 | file://0001-tests-CMakeLists.txt-do-not-search-ssh-sshd-commands.patch \ |
| 11 | file://0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | SRCREV = "e8322817a9e5aaef0698d779ddd467a209a85d85" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit cmake ptest |
| 19 | |
| 20 | PACKAGECONFIG ??= "gcrypt ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" |
| 21 | PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, " |
| 22 | PACKAGECONFIG[gcrypt] = "-DWITH_GCRYPT=1, -DWITH_GCRYPT=0, libgcrypt, " |
| 23 | PACKAGECONFIG[tests] = "-DUNIT_TESTING=1, -DUNIT_TESTING=0, cmocka" |
| 24 | |
| 25 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 26 | |
| 27 | EXTRA_OECMAKE = " \ |
| 28 | -DWITH_PCAP=1 \ |
| 29 | -DWITH_SFTP=1 \ |
| 30 | -DWITH_ZLIB=1 \ |
| 31 | -DWITH_EXAMPLES=0 \ |
| 32 | " |
| 33 | |
| 34 | do_compile:prepend () { |
| 35 | if [ ${PTEST_ENABLED} = "1" ]; then |
| 36 | sed -i -e 's|${B}|${PTEST_PATH}|g' ${B}/config.h |
| 37 | fi |
| 38 | } |
| 39 | |
| 40 | do_install_ptest () { |
| 41 | install -d ${D}${PTEST_PATH}/tests |
| 42 | cp -f ${B}/tests/unittests/torture_* ${D}${PTEST_PATH}/tests/ |
| 43 | } |
| 44 | |
| 45 | BBCLASSEXTEND = "native nativesdk" |