Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \ |
| 2 | server for multi-processor machines. It is a new implementation of the \ |
| 3 | JACK server core features that aims in removing some limitations of \ |
| 4 | the JACK1 design. The activation system has been changed for a data \ |
| 5 | flow model and lock-free programming techniques for graph access have \ |
| 6 | been used to have a more dynamic and robust system." |
| 7 | SECTION = "libs/multimedia" |
| 8 | |
| 9 | LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.1-or-later" |
| 10 | LIC_FILES_CHKSUM = " \ |
| 11 | file://common/JackControlAPI.cpp;beginline=5;endline=19;md5=9d1921199e203163f160313243f853d6 \ |
| 12 | file://common/JackControlAPI.h;beginline=4;endline=18;md5=9d1921199e203163f160313243f853d6 \ |
| 13 | file://common/jack/jack.h;beginline=2;endline=17;md5=0a668d22ce661159cad28d1c3b8e66af \ |
| 14 | file://common/JackServer.h;beginline=2;endline=17;md5=9bf0870727804a994ee2d19fd368d940 \ |
| 15 | " |
| 16 | |
| 17 | DEPENDS = "libsamplerate0 libsndfile1" |
| 18 | |
| 19 | SRC_URI = "git://github.com/jackaudio/jack2.git;branch=master;protocol=https" |
| 20 | SRCREV = "4f58969432339a250ce87fe855fb962c67d00ddb" |
| 21 | |
| 22 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | inherit waf pkgconfig |
| 27 | |
| 28 | PACKAGECONFIG ??= "alsa" |
| 29 | PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib" |
| 30 | # --dbus only stops building jackd -> add --classic |
| 31 | PACKAGECONFIG[dbus] = "--dbus --classic,,dbus" |
| 32 | PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus" |
| 33 | |
| 34 | # portaudio is for windows builds only |
| 35 | EXTRA_OECONF = "--portaudio=no" |
| 36 | |
| 37 | do_install:append() { |
| 38 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then |
| 39 | rm -f ${D}${bindir}/jack_control |
| 40 | fi |
| 41 | } |
| 42 | |
| 43 | PACKAGES =+ "libjack jack-server jack-utils" |
| 44 | |
| 45 | RDEPENDS:jack-dev:remove = "${PN} (= ${EXTENDPKGV})" |
| 46 | |
| 47 | FILES:libjack = "${libdir}/*.so.* ${libdir}/jack/*.so" |
| 48 | FILES:jack-server = " \ |
| 49 | ${datadir}/dbus-1/services \ |
| 50 | ${bindir}/jackdbus \ |
| 51 | ${bindir}/jackd \ |
| 52 | " |
| 53 | FILES:jack-utils = "${bindir}/*" |
| 54 | |
| 55 | FILES:${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*" |
| 56 | |