blob: b5c52a6edc1e13866b1520b11294146db50f74ee [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = " \
11 file://common/JackControlAPI.cpp;beginline=5;endline=19;md5=9d1921199e203163f160313243f853d6 \
12 file://common/JackControlAPI.h;beginline=4;endline=18;md5=9d1921199e203163f160313243f853d6 \
13 file://common/jack/jack.h;beginline=2;endline=17;md5=0a668d22ce661159cad28d1c3b8e66af \
14 file://common/JackServer.h;beginline=2;endline=17;md5=9bf0870727804a994ee2d19fd368d940 \
15"
16
17DEPENDS = "libsamplerate0 libsndfile1"
18
19SRC_URI = "git://github.com/jackaudio/jack2.git;branch=master;protocol=https"
20SRCREV = "4f58969432339a250ce87fe855fb962c67d00ddb"
21
22UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
23
24S = "${WORKDIR}/git"
25
26inherit waf pkgconfig
27
28PACKAGECONFIG ??= "alsa"
29PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
30# --dbus only stops building jackd -> add --classic
31PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
32PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
33
34# portaudio is for windows builds only
35EXTRA_OECONF = "--portaudio=no"
36
37do_install:append() {
38 if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then
39 rm -f ${D}${bindir}/jack_control
40 fi
41}
42
43PACKAGES =+ "libjack jack-server jack-utils"
44
45RDEPENDS:jack-dev:remove = "${PN} (= ${EXTENDPKGV})"
46
47FILES:libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
48FILES:jack-server = " \
49 ${datadir}/dbus-1/services \
50 ${bindir}/jackdbus \
51 ${bindir}/jackd \
52"
53FILES:jack-utils = "${bindir}/*"
54
55FILES:${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*"
56