Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "C++ client for Redis based on hiredis" |
| 2 | HOMEPAGE = "https://github.com/sewenew/redis-plus-plus" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 6 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 7 | SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \ |
| 8 | file://0001-include-cstdint.patch" |
| 9 | SRCREV = "f3b19a8a1f609d1a1b79002802e5cf8c336dc262" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake |
| 14 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 15 | EXTRA_OECMAKE += "-DREDIS_PLUS_PLUS_USE_TLS=ON" |
| 16 | |
| 17 | DEPENDS += "hiredis openssl" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 18 | |
| 19 | RDEPENDS:${PN} += "hiredis" |
| 20 | |
| 21 | FILES_SOLIBSDEV = "" |
| 22 | FILES:${PN} += " ${libdir}/libredis++.so*" |
| 23 | |
| 24 | INSANE_SKIP:${PN} += "dev-so" |