blob: af0d36259e4a7acb621c2d3f318081c6a75c8dad [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Parsec Command Line Interface"
2HOMEPAGE = "https://github.com/parallaxsecond/parsec-tool"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6inherit cargo cargo-update-recipe-crates
7
Patrick Williams73bd93f2024-02-20 08:07:48 -06008SRC_URI += "\
9 crate://crates.io/parsec-tool/${PV} \
10 file://0001-parsec-cli-tests.sh-adapt-to-new-serialNumber-output.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060011"
12SRC_URI[parsec-tool-0.7.0.sha256sum] = "76afb4416d04c5af9f81285dfff390b09c6926aabd6b4ee20dc07470a9698732"
13
14B = "${CARGO_VENDORING_DIRECTORY}/${BP}"
15
16do_install() {
17 install -d ${D}/${bindir}
18 install -m 755 "${B}/target/${CARGO_TARGET_SUBDIR}/parsec-tool" "${D}${bindir}/parsec-tool"
19 install -m 755 "${S}/tests/parsec-cli-tests.sh" "${D}${bindir}/parsec-cli-tests.sh"
20}
21
22require parsec-tool-crates.inc
23
24RDEPENDS:${PN} = "openssl-bin"
25
26# The QA check has been temporarily disabled. An issue has been created
27# upstream to fix this.
28# https://github.com/parallaxsecond/parsec-tool/issues/94
29INSANE_SKIP:${PN}-dbg += "buildpaths"