Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | SUMMARY = "GSL: Guidelines Support Library" |
| 2 | DESCRIPTION = "The Guidelines Support Library (GSL) contains functions \ |
| 3 | and types that are suggested for use by the C++ Core Guidelines \ |
| 4 | maintained by the Standard C++ Foundation. \ |
| 5 | This repo contains Microsoft's implementation of GSL." |
| 6 | HOMEPAGE = "https://github.com/microsoft/GSL" |
| 7 | |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=363055e71e77071107ba2bb9a54bd9a7" |
| 10 | |
| 11 | SRC_URI = "git://github.com/microsoft/GSL.git;protocol=https;branch=main \ |
| 12 | file://run-ptest \ |
| 13 | file://0001-Fix-initialization-in-test-1140.patch \ |
| 14 | file://0002-Fix-gcc-build-problem.patch \ |
| 15 | file://0003-Adapt-check_cxx_compiler_flag-to-cmake-3.0.2.patch \ |
| 16 | " |
| 17 | SRCREV = "a3534567187d2edc428efd3f13466ff75fe5805c" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit cmake pkgconfig ptest |
| 22 | |
| 23 | # this is header-only library |
| 24 | ALLOW_EMPTY:${PN} = "1" |
| 25 | |
| 26 | PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'ptest','', d)}" |
| 27 | PACKAGECONFIG[ptest] = "-DGSL_TEST=ON,-DGSL_TEST=OFF,googletest" |
| 28 | |
| 29 | # clang disagrees with https://github.com/google/googletest/pull/3457 |
| 30 | CXXFLAGS:append:toolchain-clang = " -Wno-error=switch-default" |
| 31 | # Disable disabled-macro-expansion warning as error as its seen on musl |
| 32 | CXXFLAGS:append:toolchain-clang:libc-musl = " -Wno-error=disabled-macro-expansion" |
| 33 | |
| 34 | do_install_ptest() { |
| 35 | install -d ${D}${bindir} |
| 36 | install -m 0755 ${B}/tests/gsl_tests ${D}${bindir} |
| 37 | install -m 0755 ${B}/tests/gsl_noexcept_tests ${D}${bindir} |
| 38 | } |
| 39 | |
| 40 | FILES:${PN}-ptest = "${bindir}/gsl*_tests" |
| 41 | |
| 42 | # there is already other gsl recipe, so recipe name does not match the real component name |
| 43 | CVE_PRODUCT = "microsoft:gsl" |
| 44 | |
| 45 | BBCLASSEXTEND = "native nativesdk" |