Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "MessagePack implementation for C and C++" |
| 2 | DESCRIPTION = "MessagePack is an efficient binary serialization format. It's like JSON. but fast and small" |
| 3 | HOMEPAGE = "http://msgpack.org/index.html" |
| 4 | LICENSE = "BSL-1.0" |
| 5 | LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \ |
| 6 | file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \ |
| 7 | file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \ |
| 8 | " |
| 9 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | SRC_URI = "git://github.com/msgpack/msgpack-c;branch=c_master;protocol=https \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | " |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 12 | SRCREV = "8160ede5e20fd3019a77eea46d9c72cf6163f802" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake pkgconfig |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 17 | |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 18 | EXTRA_OECMAKE += "-DMSGPACK_BUILD_TESTS=off" |
| 19 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 20 | BBCLASSEXTEND += "native nativesdk" |