Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 1 | SUMMARY="SSD1306 OLED I2C drive" |
| 2 | DESCRIPTION = "SSD1306 OLED I2C driver working in Linux" |
| 3 | HOMEPAGE = "https://github.com/armlabs/ssd1306_linux" |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "MIT" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7b694e603a996c3bfdc6093ed1f70c8f" |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | git://github.com/armlabs/ssd1306_linux.git;protocol=https;branch=master \ |
| 11 | " |
| 12 | SRCREV = "34b42992a43fda69c6ba2557b718601cafe16251" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | # coreutils provides fmt which is used in the Makefile |
| 17 | DEPENDS = "i2c-tools coreutils-native" |
| 18 | |
| 19 | EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'" |
| 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}${bindir} |
| 23 | install -m 0755 ${B}/ssd1306_bin ${D}${bindir} |
| 24 | } |