blob: c540445d7e7caa47f7968cf4acec28fb11673453 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001require wireguard.inc
2
Andrew Geissler4b7c1152020-11-30 19:55:29 -06003SRCREV = "fe402261666821514377d06c2c68ed9bc19e7634"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004
5SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat"
6
7inherit module kernel-module-split
8
9DEPENDS = "virtual/kernel libmnl"
10
11# This module requires Linux 3.10 higher and several networking related
12# configuration options. For exact kernel requirements visit:
13# https://www.wireguard.io/install/#kernel-requirements
14
15EXTRA_OEMAKE_append = " \
16 KERNELDIR=${STAGING_KERNEL_DIR} \
17 "
18
19MAKE_TARGETS = "module"
20
21RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit"
22MODULE_NAME = "wireguard"
23
24# Kernel module packages MUST begin with 'kernel-module-', otherwise
25# multilib image generation can fail.
26#
27# The following line is only necessary if the recipe name does not begin
28# with kernel-module-.
29PKG_${PN} = "kernel-module-${MODULE_NAME}"
30
31module_do_install() {
32 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
33 install -m 0644 ${MODULE_NAME}.ko \
34 ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
35}
Andrew Geisslerd688a012020-09-18 13:36:00 -050036
37# WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required.
38# OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds
39# for reference machines e.g. qemu
40EXCLUDE_FROM_WORLD = "1"