Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Crypto and TLS for C++11" |
| 2 | HOMEPAGE = "https://botan.randombit.net" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://license.txt;md5=a02e03c8fa2c5e7b9b3fcc1b9811fd3b" |
| 5 | SECTION = "libs" |
| 6 | |
| 7 | SRC_URI = "https://botan.randombit.net/releases/Botan-${PV}.tar.xz" |
| 8 | SRC_URI[md5sum] = "ebc68c08b99bbc4b4fc9bdbfad398b02" |
| 9 | SRC_URI[sha256sum] = "0c10f12b424a40ee19bde00292098e201d7498535c062d8d5b586d07861a54b5" |
| 10 | |
| 11 | S = "${WORKDIR}/Botan-${PV}" |
| 12 | |
| 13 | inherit python3native siteinfo lib_package |
| 14 | |
| 15 | CPU ?= "${TARGET_ARCH}" |
| 16 | CPU_x86 = "x86_32" |
| 17 | CPU_armv7a = "armv7" |
| 18 | CPU_armv7ve = "armv7" |
| 19 | |
| 20 | do_configure() { |
| 21 | python3 ${S}/configure.py \ |
| 22 | --prefix="${D}${exec_prefix}" \ |
| 23 | --libdir="${D}${libdir}" \ |
| 24 | --cpu="${CPU}" \ |
| 25 | --cc-bin="${CXX}" \ |
| 26 | --cxxflags="${CXXFLAGS}" \ |
| 27 | --ldflags="${LDFLAGS}" \ |
| 28 | --with-endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \ |
| 29 | ${@bb.utils.contains("TUNE_FEATURES","neon","","--disable-neon",d)} \ |
| 30 | --with-sysroot-dir=${STAGING_DIR_HOST} \ |
| 31 | --with-build-dir="${B}" \ |
| 32 | --optimize-for-size \ |
| 33 | --with-stack-protector \ |
| 34 | --enable-shared-library \ |
| 35 | --with-python-versions=3 \ |
| 36 | ${EXTRA_OECONF} |
| 37 | } |
| 38 | |
| 39 | do_compile() { |
| 40 | oe_runmake |
| 41 | } |
| 42 | do_install() { |
| 43 | oe_runmake install |
| 44 | sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-2.pc |
| 45 | } |
| 46 | |
| 47 | PACKAGES += "${PN}-python3" |
| 48 | |
| 49 | FILES_${PN}-python3 = "${libdir}/python3" |
| 50 | |
| 51 | RDEPENDS_${PN}-python3 += "python3" |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame^] | 52 | |
| 53 | COMPATIBLE_HOST_riscv32 = "null" |