Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A pure-Python MySQL client library" |
| 2 | DESCRIPTION = " \ |
| 3 | This package contains a pure-Python MySQL client library, based on PEP 249 \ |
| 4 | Most public APIs are compatible with mysqlclient and MySQLdb. \ |
| 5 | " |
| 6 | SECTION = "devel/python" |
| 7 | HOMEPAGE = "https://pymysql.readthedocs.io" |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc" |
| 10 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 11 | SRC_URI[md5sum] = "4a1fe973afbbdd78928650118ce8ff68" |
| 12 | SRC_URI[sha256sum] = "263040d2779a3b84930f7ac9da5132be0fefcd6f453a885756656103f8ee1fdd" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | PYPI_PACKAGE = "PyMySQL" |
| 15 | inherit pypi setuptools3 |
| 16 | |
| 17 | RDEPENDS_${PN} += "${PYTHON_PN}-cryptography" |