Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "TinyALSA is a small library to interface with ALSA in \ |
| 2 | the Linux kernel. It is a lightweight alternative to libasound." |
| 3 | HOMEPAGE = "https://github.com/tinyalsa/tinyalsa" |
| 4 | SECTION = "libs/multimedia" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b" |
| 8 | |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 9 | SRCREV = "8449529c7e50f432091539ba7b438e79b04059b5" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 10 | SRC_URI = "git://github.com/tinyalsa/tinyalsa \ |
| 11 | file://0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch \ |
| 12 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | PV = "1.1.1+git${SRCPV}" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit cmake |
| 18 | |
| 19 | # tinyalsa is built as a static library. Enable PIC to avoid relocation |
| 20 | # errors like these: |
| 21 | # |
| 22 | # unresolvable R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `stderr@@GLIBC_2.17' |
| 23 | CFLAGS += " -fPIC -DPIC " |