Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Construct and optionally mail MIME messages" |
| 2 | DESCRIPTION = "Constructs and (by default) mails MIME messages. \ |
| 3 | It is entirely driven from the command line, it is \ |
| 4 | designed to be used by other programs, or people who act \ |
| 5 | like programs." |
| 6 | HOMEPAGE = "http://search.cpan.org/~rosch/mime-construct/mime-construct" |
| 7 | SECTION = "mail" |
| 8 | LICENSE = "GPLv2+" |
| 9 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=5e2e5da619ac8ef8c84767ccc4656e96" |
| 10 | |
| 11 | SRC_URI = "${CPAN_MIRROR}/authors/id/R/RO/ROSCH/mime-construct-${PV}.tar.gz \ |
| 12 | file://fix-mime-construct-help-return-value.patch \ |
| 13 | " |
| 14 | |
| 15 | SRC_URI[md5sum] = "73834ea780fbea81b89dbd9b2fb54f58" |
| 16 | SRC_URI[sha256sum] = "4cd7bb61b51d41192d1498c1051aa6a4ccd75aeb09b71d2ec706a7084a4a9303" |
| 17 | |
| 18 | inherit cpan |
| 19 | |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 20 | RDEPENDS_${PN} += "libmime-types-perl libproc-waitstat-perl msmtp \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 21 | perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \ |
| 22 | " |
| 23 | |
| 24 | do_install_append() { |
| 25 | #change the interpreter in file |
| 26 | sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl -w|${bindir}/env perl|g" \ |
| 27 | ${D}/${bindir}/mime-construct |
| 28 | } |