Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Meta-perl packagegroup" |
| 2 | |
| 3 | inherit packagegroup |
| 4 | |
| 5 | PROVIDES = "${PACKAGES}" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 6 | PACKAGES = "\ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | packagegroup-meta-perl \ |
| 8 | packagegroup-meta-perl-extended \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 9 | ${@bb.utils.contains("DISTRO_FEATURES", "ptest", "packagegroup-meta-perl-ptest-packages", "", d)} \ |
| 10 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | |
| 12 | RDEPENDS_packagegroup-meta-perl = "\ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | adduser \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 14 | libalgorithm-diff-perl \ |
| 15 | libauthen-sasl-perl \ |
| 16 | libauthen-radius-perl \ |
| 17 | libcapture-tiny-perl \ |
| 18 | libcgi-perl \ |
| 19 | libdbd-sqlite-perl \ |
| 20 | libclass-method-modifiers-perl \ |
| 21 | libdigest-hmac-perl \ |
| 22 | libdigest-sha1-perl \ |
| 23 | libconfig-autoconf-perl \ |
| 24 | libcrypt-openssl-guess-perl \ |
| 25 | libcrypt-openssl-random-perl \ |
| 26 | libcrypt-openssl-rsa-perl \ |
| 27 | libhtml-parser-perl \ |
| 28 | libhtml-tree-perl \ |
| 29 | libhtml-tagset-perl \ |
| 30 | libimport-into-perl \ |
| 31 | libio-socket-ssl-perl \ |
| 32 | libio-stringy-perl \ |
| 33 | libipc-signal-perl \ |
| 34 | libcurses-perl \ |
| 35 | libmime-charset-perl \ |
| 36 | libmime-types-perl \ |
| 37 | libmodule-pluggable-perl \ |
| 38 | libmodule-runtime-perl \ |
| 39 | libmodule-build-tiny-perl \ |
| 40 | libdata-hexdump-perl \ |
| 41 | libnet-dns-perl \ |
| 42 | libnet-libidn-perl \ |
| 43 | libnet-dns-sec-perl \ |
| 44 | libnet-ldap-perl \ |
| 45 | libnet-ssleay-perl \ |
| 46 | libnet-telnet-perl \ |
| 47 | libproc-waitstat-perl \ |
| 48 | libdevel-globaldestruction-perl \ |
| 49 | libenv-perl \ |
| 50 | libfile-slurp-perl \ |
| 51 | libfile-slurper-perl \ |
| 52 | libtext-iconv-perl \ |
| 53 | libtext-diff-perl \ |
| 54 | libtext-charwidth-perl \ |
| 55 | libtext-wrapi18n-perl \ |
| 56 | libxml-libxml-perl \ |
| 57 | libxml-filter-buffertext-perl \ |
| 58 | libxml-sax-writer-perl \ |
| 59 | libextutils-config-perl \ |
| 60 | libextutils-cppguess-perl \ |
| 61 | libextutils-helpers-perl \ |
| 62 | libextutils-installpaths-perl \ |
| 63 | libextutils-parsexs-perl \ |
| 64 | liblocale-gettext-perl \ |
| 65 | libmoo-perl \ |
| 66 | librole-tiny-perl \ |
| 67 | libunix-statgrab \ |
| 68 | libstrictures-perl \ |
| 69 | libsub-exporter-progressive-perl \ |
| 70 | libsub-uplevel-perl \ |
| 71 | libterm-readkey-perl \ |
| 72 | libtest-deep-perl \ |
| 73 | libtest-harness-perl \ |
| 74 | libtest-nowarnings-perl \ |
| 75 | libtest-warn-perl \ |
| 76 | libtest-warnings-perl \ |
| 77 | libunicode-linebreak-perl \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 78 | po4a \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 79 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 80 | |
| 81 | RDEPENDS_packagegroup-meta-perl-extended = "\ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 82 | logcheck \ |
| 83 | mime-construct \ |
| 84 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 85 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 86 | RDEPENDS_packagegroup-meta-perl-ptest-packages = "\ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 87 | libmime-types-perl-ptest \ |
| 88 | libio-socket-ssl-perl-ptest \ |
| 89 | libdata-hexdump-perl-ptest \ |
| 90 | libauthen-sasl-perl-ptest \ |
| 91 | libnet-dns-perl-ptest \ |
| 92 | libnet-dns-sec-perl-ptest \ |
| 93 | libnet-ssleay-perl-ptest \ |
| 94 | libtest-harness-perl-ptest \ |
| 95 | libdigest-sha1-perl-ptest \ |
| 96 | libdigest-hmac-perl-ptest \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 97 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 98 | |
| 99 | EXCLUDE_FROM_WORLD = "1" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 100 | |
| 101 | # perl-module-encode is preferred over libencode-perl |
| 102 | # libencode-locale-perl depends on libencode-perl |