Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "An asynchronous event notification library" |
| 2 | HOMEPAGE = "http://libevent.org/" |
| 3 | BUGTRACKER = "https://github.com/libevent/libevent/issues" |
| 4 | SECTION = "libs" |
| 5 | |
| 6 | LICENSE = "BSD & MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549" |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \ |
| 11 | file://Makefile-missing-test-dir.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | file://0001-test-fix-32bit-linux-regress.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "f3eeaed018542963b7d2416ef1135ecc" |
| 17 | SRC_URI[sha256sum] = "965cc5a8bb46ce4199a47e9b2c9e1cae3b137e8356ffdad6d94d3b9069b71dc2" |
| 18 | |
| 19 | UPSTREAM_CHECK_URI = "http://libevent.org/" |
| 20 | |
| 21 | S = "${WORKDIR}/${BPN}-${PV}-stable" |
| 22 | |
| 23 | PACKAGECONFIG ??= "" |
| 24 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| 25 | |
| 26 | inherit autotools |
| 27 | |
| 28 | # Needed for Debian packaging |
| 29 | LEAD_SONAME = "libevent-2.1.so" |
| 30 | |
| 31 | inherit ptest |
| 32 | |
| 33 | DEPENDS = "zlib" |
| 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |
| 36 | |
| 37 | do_install_ptest() { |
| 38 | install -d ${D}${PTEST_PATH}/test |
| 39 | for file in ${B}/test/.libs/regress ${B}/test/.libs/test* |
| 40 | do |
| 41 | install -m 0755 $file ${D}${PTEST_PATH}/test |
| 42 | done |
| 43 | } |