blob: bdadf7c77464e60a22a94e3dacbb647480611750 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "SDK for connecting to AWS IoT using Python."
2HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python"
3LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)"
4LICENSE:${PN}-examples = "Apache-2.0"
5LIC_FILES_CHKSUM = "\
6 file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \
7 file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \
8"
Patrick Williams03907ee2022-05-01 06:28:52 -05009SRCREV = "0ea1a2d013529839fc1e7448d19dadff25d581b4"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010SRC_URI = "git://github.com/aws/aws-iot-device-sdk-python;branch=master;protocol=https \
11 file://0001-setup.py-Use-setuptools-instead-of-distutils.patch \
12 "
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
18PYPI_PACKAGE = "AWSIoTPythonSDK"
19
20do_install:append() {
21 install -d -m0755 ${D}${datadir}/${BPN}/examples
22 cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples
23 # this requires the full blown AWS Python SDK
24 rm -r ${D}${datadir}/${BPN}/examples/basicPubSub
25}
26
27PACKAGES =+ "${PN}-examples"
28
29RDEPENDS:${PN} += " \
Patrick Williams39653562024-03-01 08:54:02 -060030 python3-crypt \
31 python3-datetime \
32 python3-io \
33 python3-json \
34 python3-logging \
35 python3-math \
36 python3-netclient \
37 python3-numbers \
38 python3-threading \
Andrew Geissler9aee5002022-03-30 16:27:02 +000039"
40RDEPENDS:${PN}-examples += "${PN}"
41
42FILES:${PN}-examples = "${datadir}/${BPN}/examples"
43
44BBCLASSEXTEND = "native nativesdk"