Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 1 | SUMMARY = "Extensions to the standard Python datetime module" |
| 2 | DESCRIPTION = "The dateutil module provides powerful extensions to the datetime module available in the Python standard library." |
| 3 | HOMEPAGE = "https://dateutil.readthedocs.org" |
| 4 | LICENSE = "BSD-3-Clause & Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996" |
| 6 | |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "78e73e19c63f5b20ffa567001531680d939dc042bf7850431877645523c66709" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 8 | |
| 9 | PYPI_PACKAGE = "python-dateutil" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | PIP_INSTALL_PACKAGE = "python_dateutil" |
| 11 | inherit pypi python_setuptools_build_meta |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 12 | |
| 13 | PACKAGES =+ "${PN}-zoneinfo" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 14 | FILES:${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 15 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 16 | DEPENDS += "python3-setuptools-scm-native" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | RDEPENDS:${PN} = "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 19 | python3-datetime \ |
| 20 | python3-numbers \ |
| 21 | python3-six \ |
| 22 | python3-stringold \ |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 23 | " |
| 24 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 25 | BBCLASSEXTEND = "native nativesdk" |