blob: 5180301f7b812fc48676798f448a4d6633c4fbe7 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "MessagePack (de)serializer"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
4
5inherit pypi setuptools3 ptest
6
7SRC_URI[sha256sum] = "572efc93db7a4d27e404501975ca6d2d9775705c2d922390d878fcf768d92c87"
8
9RDEPENDS:${PN}:class-target += "\
Patrick Williams39653562024-03-01 08:54:02 -060010 python3-io \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060011"
12
13BBCLASSEXTEND = "native nativesdk"
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
Patrick Williams39653562024-03-01 08:54:02 -060020 python3-pytest \
21 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060022"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/test
26 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
27}