Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 1 | SUMMARY = "A network address manipulation library for Python." |
| 2 | LICENSE = "BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=8afa43eca873b71d5d85dd0be1f707fa" |
| 4 | |
| 5 | SRC_URI[sha256sum] = "6eb8fedf0412c6d294d06885c110de945cf4d22d2b510d0404f4e06950857987" |
| 6 | |
| 7 | inherit pypi python_setuptools_build_meta ptest |
| 8 | |
| 9 | SRC_URI += " \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | |
| 13 | RDEPENDS:${PN}-ptest += " \ |
| 14 | python3-pytest \ |
| 15 | python3-unittest-automake-output \ |
| 16 | " |
| 17 | |
| 18 | do_install_ptest() { |
| 19 | install -d ${D}${PTEST_PATH}/tests |
| 20 | cp -rf ${S}/netaddr/tests/* ${D}${PTEST_PATH}/tests/ |
| 21 | } |
| 22 | |