blob: 082e7c5025a5b47c5e816e6f8af8bcde607be681 [file] [log] [blame]
Patrick Williamsb58112e2024-03-07 11:16:36 -06001SUMMARY = "A network address manipulation library for Python."
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=8afa43eca873b71d5d85dd0be1f707fa"
4
5SRC_URI[sha256sum] = "6eb8fedf0412c6d294d06885c110de945cf4d22d2b510d0404f4e06950857987"
6
7inherit pypi python_setuptools_build_meta ptest
8
9SRC_URI += " \
10 file://run-ptest \
11"
12
13RDEPENDS:${PN}-ptest += " \
14 python3-pytest \
15 python3-unittest-automake-output \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/netaddr/tests/* ${D}${PTEST_PATH}/tests/
21}
22